Tested VST Plug-ins

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Tested VST Plug-ins
  • In order to fully test a VST plug-In, please follow these steps and report back here.


    Firstly please try and get these informations.

    1) Plugin Name & Manufacturer

    2) Plugin version: Which version? Full version or demo version?

    3) OS version: what is your operating system?


    At this point you may want to uninstall and then reinstall the Ohm Studio if you believe that the plug-in you're testing is not working properly.
    See here for the uninstall procedure.
    Removing the cache and preferences should be enough (step 1 and 2 on Mac, step 4 and 5 on Windows).


    4) VST Scan: Does the initial scanning process make the ohm studio crash/freeze? Dou you see the VST plug-in in the Gear-List?

    5) Instantiating the plugin. Does the plug-in make the Ohm Studio crash when you drag&drop it on the Gear Panel?

    6) Audio. Does it make any sound (VST instruments)? Or does it process audio correctly (VST effects) ?

    7) Changing presets/parameters. Does changing the preset (or any
    parameters if the plugin doesn't have presets) on the plug-in's GUI
    affect the sound?

    8) Inspector. Can you control the plug-in's parameters from the Plugin Inspector?

    9) Loading presets/parameters : If you change the plug-in's preset
    (or any parameters if the plugin doesn't have presets), close the
    project, then open it again, does the plug-in load the right preset or
    does it load the default preset? In other words, does the plug-in
    remember the changes you made last time you worked on that project?




    Here is an example:

    1) Alchemy Player - Camel Audio

    2) Demo version - 1.20.1.P

    3) Mac OS X 10.6.7

    4) VST scan OK.

    5) Instantiating OK

    6) Audio OK

    7) Preset change OK

    8) Inspector OK

    9) Re-loading project OK



    Thank you for your time and cooperation.

    ———————————

    Quick summary of (y)our findings:


    ==================================
    Windows
    ==================================

    Pass

    Absynth, Native Instruments - v 4.0.5.003 full
    Aether, 2C Audio - v 1.5.1 full
    Albino, LinPlug - 3.0.2 full
    Arp2600, Arturia - v 2.0 full
    Battery 3   Native Instruments - Full Version 3.2.2
    BlueVerb DRV-2080, Nomad Factory - v 1.7 full
    BT Analog Chorus CH2S-3, Nomad Factory- v 3.6 full
    BT Analog Phaser APH-2S, Nomad Factory - v 3.6 full
    BT BrickWall BW2S-3, Nomad Factory - v 3.6 full
    BT Equalizer GEQ12-3, Nomad Factory - v 3.6 full
    BT Equalizer PEQ2B-3, Nomad Factory - v 3.6 full
    BT Equalizer PEQ5B-3, Nomad Factory - v 3.6 full
    CamelPhat, Camel Audio - v 3.15 full
    CS-80V, Arturia - v 2.0 full
    Delta III, LinPlug - v 3.05 full
    EQ 9063B All-Tech, Nomad Factory - v 1.1 full
    FL Studio, Image Line - v 10.0.2 full
    Jupiter-8V, Arturia - v 2.0 full
    LM Amplifier LM-662, Nomad Factory - v 1.6 full
    Midnight Compressor / Midnight EQ, Focusrite - v 1.1 full
    Moog Modular V2, Arturia - v 2.5 full
    Nexus, reFX - v 2.2.0 full
    Prophet-V, Arturia - v 2.0 full
    Sandra, FSynthz.com - ?? full
    Vanguard, reFX - v 1.8.0 full
    z3ta+, RGC Audio - v 1.1 full

    Fail

    A.M.T. Amp Leveling, Nomad Factory - v 1.3 full
    A.M.T. Max Warm, Nomad Factory - v 1.3 full
    A.M.T. Multi Max, Nomad Factory - v 1.3 full
    Alchemy Player - Camel Audio - Player version - 1.20.1P (32 Bit VST)
    British MCL-2269, Nomad Factory - v 1.2 full
    British NEQ-1972, Nomad Factory - v 1.2 full
    BT Analog TrackBox, Nomad Factory - v 3.6 full
    BT Equalizer PEQ322-3, Nomad Factory - v 3.6 full
    BT Compressor CP2S-3, Nomad Factory - v 3.6 full
    BT Compressor FA770-3, Nomad Factory - v 3.6 full
    BT DeEsser DS2S-3, Nomad Factory - v 3.6 full
    GURU / FXpansion (Freebie included with Computer Music Mag)
    impOSCar, GForce - v 1.0.1 full
    Korg Legacy (Including Legacy and MS20/MS20fx; Polysix; Wavestation) - ver 1.x
    Mach Five 2.02 Motu
    Melda  Plugins - Melda Production - Melda Total Bundle 5.02 (32 Bit VST)
    Melda  Plugins - Melda Production - MDrummer Small 4.00 (32 Bit VST)
    Pro-53, Native Instruments - v 3.00.013 full
    Pro-52, Native Instruments - v 2.5.0 full
    Akoustik Piano, Native Instruments - v 1.1.3.001 full
    B4 II, Native Instruments - v 2.0.4.001 full
    Battery, Native Instruments - v 3.2.2 full
    Brass, Arturia - v 2.0.5 full
    ECHOS, Nomad Factory - v 1.0 full
    Glitch, dBlue - v 1.3.05 full
    Grossbeat, Image Line - v 1.0.7 full
    Guitar Rig 3, Native Instruments - v 3.1.0.005 full
    Harmless, Image Line - v 1.0.8 full
    Kontakt, Native Instruments - v 4.2.3 full
    MAGNETIC, Nomad Factory - v 1.4.1 full
    Massive, Native Instruments - v 1.2.1 full
    Maximus, Image Line - v 1.0.9 full
    Minimoog-V2, Arturia - v 2.0.1 full
    Morphine, Image Line - v 1.5.4 full
    Nectar, iZotope - v 1.1.0 full
    Sytrus, Image Line - v 2.6.12 full
    Superior Drummer 2.0 - Toontack - Full version - 2
    Toxic Biohazard, Image Line - v 1.1.4 full
    Valhalla Room, Valhalla DSP - v 1.0.7 full
    Yellow Tools Independence Free - ver 2.5

    Suspicious

    Dimension Pro - Cakewalk
    Play engine  (Fab Four/Ministry of Rock/Gypsy/Goliath/EWSO/SD2 -East/West


    ==================================
    Mac
    ==================================


    Pass


    Alchemy Player - Camel Audio

    Kore2 / Kore2 Player - Native Instruments - Full Versions 2.1.2


    Fail



    Suspicious

  • These are a few that Ive used in Ohmstudio:

    1.  Dimension Pro - Cakewalk

    2.  Full Version 1.2

    3.  Windows 7

    4.  VST Scan OK

    5. Instantiating OK

    6.  Audio OK

    7.  Preset change OK

    8.  Inspector OK

    9.  Re-loading project......needs to be reloaded if not frozen....

  • 1. Play engine  (Fab Four/Ministry of Rock/Gypsy/Goliath/EWSO/SD2 -East/West

    2. Full Version 2.1.2

    3. Windows 7

    4. VST Scan OK

    5. Instantiating OK

    6. Audio OK

    7. Preset change OK

    8. Inspector OK

    9. Re-loading project ... needs to be reloaded sometimes, if not frozen

     

  • 1. Battery 3   Native Instruments

    2. Full Version 3.2.2

    3. Windows 7

    4. VST Scan OK

    5. Instantiating OK

    6. Audio OK

    7. Preset Change OK

    8. Inspector OK

    9. Re-loading project OK

  • 1. Kontakt 4   Native Instruments

    2. Full Version 4.2.3

    3. Windows 7

    4. VST Scan OK

    5. Instantiating OK

    6. Audio OK

    7. Preset Change OK

    8. Inspector OK

    9. Re-loading project OK

  • Korg Legacy (Including Legacy and MS20/MS20fx; Polysix; Wavestation)
    ver 1.x
    Win 7 64
    Failed VST Scan

    Yellow Tools Independence Free
    ver 2.5
    Win 7 64
    Failed VST Scan

    P.S. am only going to list failures, unless you want sucesses as well

  • 1) Superior Drummer 2.0 - Toontack

    2) Full version - 2

    3) Windows 7 x64 (32 bit VST)

    4) VST scan OK.

    5) Instantiating OK

    6) Audio -- OK

    7) Preset change -- OK

    8) Inspector --  crash on adjusting master volume, mixer settings, many other features in VST UI

    9) Re-loading project OK
  • 1) Alchemy Player - Camel Audio

    2) Player version - 1.20.1P (32 Bit VST)

    3) Win 7 (64 Bit)

    4) VST scan, OK

    5) Instantiating, OK

    6) Audio, OK

    7) Preset change, OK

    8) Inspector, OK

    9) Re-loading project, NOT OK - does not retain settings and reverts to default
  • 1) MELDA PLUGINS - MELDA PRODUCTION

    2) MELDA TOTAL BUNDLE 5.02 (32 Bit VST)

    3) Win 7 (64 Bit)

    4) VST scan, OK

    5) Instantiating, OK

    6) Audio, OK

    7) Preset change, OK

    8) Inspector, OK

    9) Re-loading project, NOT OK - does remember changes on the default preset but doesn´t remember presets or changes on presets.
  • 1) MELDA PLUGINS - MELDA PRODUCTION

    2) MDRUMMER SMALL 4.00 (32 Bit VST)

    3) Win 7 (64 Bit)
    4) VST scan, OK

    5) Instantiating, OK

    6) Audio, OK

    7) Preset change, OK

    8) Inspector, OK

    9) Re-loading project, NOT OK - goes back to default.

    10) The next second after recording (when you hit stop), spontaneously delete the recordings.
  • Good:

    1. Albino, LinPlug
    2. v 3.0.2 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - OK

    1. Absynth, Native Instruments
    2. v 4.0.5.003 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - OK

    1. Arp2600, Arturia
    2. v 2.0 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - OK

    1. CS-80V, Arturia
    2. v 2.0 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - OK

    1. CamelPhat, Camel Audio
    2. v 3.15 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - OK


    1. Jupiter-8V, Arturia
    2. v 2.0 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - OK

    1. Midnight Compressor / Midnight EQ, Focusrite
    2. v 1.1 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Parameter change - OK
    8. Inspector - OK
    9. Re-loading project - OK

    1. Sandra, FSynthz.com
    2. ?? full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Parameter change - OK
    8. Inspector - OK
    9. Re-loading project - OK

    1. Nexus, reFX
    2. v 2.2.0 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - OK

    1. Vanguard, reFX

    2. v 1.8.0 full

    3. Windows 7 64-bit

    4. VST scan - OK

    5. Instantiating - OK

    6. Audio - OK

    7. Preset change - OK

    8. Inspector - OK

    9. Re-loading project - OK

    1. Prophet-V, Arturia

    2. v 2.0 full

    3. Windows 7 64-bit

    4. VST scan - OK

    5. Instantiating - OK

    6. Audio - OK

    7. Preset change - OK

    8. Inspector - OK

    9. Re-loading project - OK

    1. Moog Modular V2, Arturia
    2. v 2.5 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Can control parameters from Inspector, but cannot establish connections between parameters (oscillators/filters/envelopes/etc.)
    9. Re-loading project - OK

    1. z3ta+, RGC Audio
    2. v 1.1 full
    3. Windows 7 64-bit


    4. VST scan - OK


    5. Instantiating - OK


    6. Audio - OK


    7. Preset change - OK


    8. Inspector - OK


    9. Re-loading project - OK

    1. FL Studio, Image Line

    2. v 10.0.2 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK - Works correctly as a vst/rewire plugin
    7. not applicable
    8. Can control several overall parameters from Inspector
    9. Re-loading project - OK
    ______________________
    Issues:

    1. impOSCar, GForce
    2. v 1.0.1 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Presets work on initial load
    8. Inspector - OK
    9. Upon closing/reopening, all tweaks/knobs remained where they were when closed, but all presets are absent from the instanced plug-in. Tested without tweaking from preset, and also had all presets disappear.

    1. Pro-53, Native Instruments
    2. v 3.00.013 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Upon closing/reopening, all tweaks/knob positions were lost where they were when closed, but all presets are still available.

    1. Pro-52, Native Instruments
    2. v 2.5.0 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Upon closing/reopening, all tweaks/knob positions were lost where they were when closed, but all presets are still available.

    1. Akoustik Piano, Native Instruments
    2. v 1.1.3.001 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Presets work on initial load
    8. Can control some basic parameters from Inspector but not all
    9. Upon closing/reopening, all tweaks/knobs were reset, the previous preset was not loaded, and all presets are available.

    1. B4 II, Native Instruments
    2. v 2.0.4.001 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Upon closing/reopening, all tweaks/knob positions were lost where they were when closed, loads the last preset without adjustments, and all presets are still available.

    1. Battery, Native Instruments
    2. v 3.2.2 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK - Will load kits
    8. Can control some basic parameters from Inspector, but no midi cc control
    9. Upon closing/reopening, all tweaks/knob positions were lost where they were when closed, loads the last kit sans any previous adjustments, and all kits are still available.

    1. Brass, Arturia
    2. v 2.0.5 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK - Loads kits and individual instruments
    8. Can control parameters through Inspector - however most control is based off of velocity so Inspector is not useful for this plugin. Turning any of the parameters to zero creates a c# error and crashes the vst
    9. Upon closing/reopening, all tweaks/knobs were reset, the previous preset was not loaded, and all presets are available.

    1. Grossbeat, Image Line
    2. v 1.0.7 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Can control slot selection through Inspector
    9. Upon closing/reopening, all tweaks/knobs were reset, the previous preset was not loaded, and all presets are available.

    1. Harmless, Image Line
    2. v 1.0.8 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Can control slot selection through Inspector
    9. Upon closing/reopening, all tweaks/knobs were reset, goes to default - the previous preset was not loaded, and all presets are available.

    1. Maximus, Image Line
    2. v 1.0.9 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Upon closing/reopening, all tweaks/knobs were reset, the previous preset was not loaded, and all presets are available.

    1. Kontakt, Native Instruments
    2. v 4.2.3 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK - Will load instruments etc.
    8. Can control some basic parameters from Inspector, but no midi cc control
    9. Upon closing/reopening, all tweaks/knob positions were lost where they were when closed, loads the last instrument used without any adjustments, and all instruments are still available.

    1. Guitar Rig 3, Native Instruments
    2. v 3.1.0.005 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset Load - OK - Will load instruments etc.
    8. Inspector - Only some parameters can be controlled through the Inspector
    9. Reloading project - OK - Upon closing/reopening, all tweaks/knob positions were where they were when closed, loads the last instrument used without any adjustments, and all instruments are still available.

    1. Massive, Native Instruments
    2. v 1.2.1 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK - Will load instruments etc.
    8. Inspector - OK
    9. Upon closing/reopening, all tweaks/knob positions were kept until the vst was opened - it then reverted to the preset that was altered, and all presets are still available.

    1. Sytrus, Image Line
    2. v 2.6.12 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Upon closing/reopening, all tweaks/knobs were reset, goes to default - the previous preset was not loaded, and all presets are available.

    1. Glitch, dBlue
    2. v 1.3.05 full
    3. Windows 7 64-bit

    4. VST scan - OK

    5. Instantiating - OK

    6. Audio - OK

    7. Parameter change - OK

    8. Inspector - OK

    9. Upon closing/reopening, all tweaks/knobs were reset, goes to default


    1. Toxic Biohazard, Image Line

    2. v 1.1.4 full

    3. Windows 7 64-bit

    4. VST scan - OK

    5. Instantiating - OK

    6. Audio - OK

    7. Preset change - OK

    8. Inspector - OK

    9. Upon closing/reopening, all tweaks/knobs were reset, goes to default -
    the previous preset was not loaded, and all presets are available.

    1. Morphine, Image Line

    2. v 1.5.4 full

    3. Windows 7 64-bit

    4. VST scan - OK

    5. Instantiating - OK

    6. Audio - OK

    7. Preset change - OK

    8. Inspector - OK

    9. Upon closing/reopening, all tweaks/knobs were reset, goes to default -
    the previous preset was not loaded, and all presets are available.

    1. Minimoog-V2, Arturia
    2. v 2.0.1 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Upon closing/reopening, all tweaks/knob positions were lost where they were when closed, loads the last preset without adjustments, and all presets are still available.
  • Wow, thanks dudes!
  • Good:

    1. Aether, 2C Audio
    2. v 1.5.1 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - OK

    1. BlueVerb DRV-2080, Nomad Factory
    2. v 1.7 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - OK

    1. BT Analog Chorus CH2S-3, Nomad Factory
    2. v 3.6 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - OK

    1. Delta III, LinPlug
    2. v 3.05 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - OK

    1. BT Equalizer PEQ2B-3, Nomad Factory
    2. v 3.6 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - OK

    1. BT Equalizer GEQ12-3, Nomad Factory
    2. v 3.6 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - OK

    1. BT Equalizer PEQ5B-3, Nomad Factory
    2. v 3.6 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - OK

    1. BT Analog Phaser APH-2S, Nomad Factory
    2. v 3.6 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - OK

    1. BT BrickWall BW2S-3, Nomad Factory
    2. v 3.6 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - OK

    1. EQ 9063B All-Tech, Nomad Factory
    2. v 1.1 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - OK

    1. LM Amplifier LM-662, Nomad Factory
    2. v 1.6 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - OK
    __________________________

    Issues:

    1. BT Analog TrackBox, Nomad Factory
    2. v 3.6 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK - Meter in/out is set as off/on, but that has no audio effect
    9. Re-loading project - OK

    1. BT Equalizer PEQ322-3, Nomad Factory
    2. v 3.6 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK - Meter in/out is set as off/on, but that has no audio effect
    9. Re-loading project - OK

    1. A.M.T. Amp Leveling, Nomad Factory
    2. v 1.3 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK - but Power switch (off/on) is backwards in Inspector
    9. Re-loading project - OK

    1. A.M.T. Max Warm, Nomad Factory
    2. v 1.3 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK - but Power switch (off/on) is backwards in Inspector
    9. Re-loading project - OK

    1. A.M.T. Multi Max, Nomad Factory
    2. v 1.3 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK - but Power switch (off/on) is backwards in Inspector
    9. Re-loading project - OK

    1. British MCL-2269, Nomad Factory
    2. v 1.2 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK - but Power and Vintage switches (off/on) are backwards in Inspector
    9. Re-loading project - OK

    1. British NEQ-1972, Nomad Factory
    2. v 1.2 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK - but Power and Phase switches (off/on) are backwards in Inspector
    9. Re-loading project - OK

    1. BT Compressor CP2S-3, Nomad Factory
    2. v 3.6 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK - Mode should be RMS/Peak instead of off/on
    9. Re-loading project - OK

    1. BT Compressor FA770-3, Nomad Factory
    2. v 3.6 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK - Attack Mode should be A/B instead of off/on
    9. Re-loading project - OK

    1. BT DeEsser DS2S-3, Nomad Factory
    2. v 3.6 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK - Filter Mode should be HPF/BPF instead of off/on
    9. Re-loading project - OK

    1. Valhalla Room, Valhalla DSP
    2. v 1.0.7 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - plugin is reset to default

    1. Nectar, iZotope
    2. v 1.1.0 full
    3. Windows 7 64-bit
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - plugin is reset to default

    1. ECHOS, Nomad Factory
    2. v 1.0 full
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - plugin is reset to default

    1. MAGNETIC, Nomad Factory
    2. v 1.4.1 full
    4. VST scan - OK
    5. Instantiating - OK
    6. Audio - OK
    7. Preset change - OK
    8. Inspector - OK
    9. Re-loading project - plugin is reset to default
  • 1) FLStudio , Image Line
    2) 10.05 full
    3) Win 7 64bit
    4) VST scan OK.
    5) Instantiating OK
    6) Audio NOT OK - if bounced online
    7) Preset change OK
    8) Inspector OK
    9) Re-loading project  OK

    FLStudio is working as plugin (not rewire), thats perfect for me. There are some problems when i bounce it online  (collaborative freeze).
    :

    -Flstudio will get closed , and everything begins to get a bit choppy, however i managed to cancel it after spamming the buttons. Actually you have to do this or the file will not get bounced.

    -there are some sounds/notes missing ( not the usual first note drop out wich FL has as plugin )

    -timestretching in FL wont be adopted

    Offline everything seem to work.


    1) Sylenth1 , Lennardigital
    2) 2.21 full
    3) Win 7 64bit
    4) VST scan OK.
    5) Instantiating OK
    6) Audio OK
    7) Preset change OK
    8) Inspector OK
    9) Re-loading project  OK


    1) Twin 2 , Fabfilter
    2) 2.11 full
    3) Win 7 64bit
    4) VST scan OK.
    5) Instantiating OK
    6) Audio OK
    7) Preset change OK
    8) Inspector OK
    9) Re-loading project NOT OK - all settings will restore correctly but the preset name is gone, sometimes it doesnt load the previous settings


    1) One , Fabfilter

    2) 3.10 full

    3) Win 7 64bit

    4) VST scan OK.

    5) Instantiating OK

    6) Audio OK

    7) Preset change OK

    8) Inspector OK

    9) Re-loading project NOT OK - all settings will restore correctly but the preset name is gone, sometimes it doesnt load the previous settings

    1) Volcano 2 , Fabfilter

    2) 2.10 full

    3) Win 7 64bit

    4) VST scan OK.

    5) Instantiating OK

    6) Audio OK

    7) Preset change OK

    8) Inspector OK

    9) Re-loading project NOT OK - all settings will restore correctly but the preset name is gone


    1) Timeless 2 , Fabfilter

    2) 2.10 full

    3) Win 7 64bit

    4) VST scan OK.

    5) Instantiating OK

    6) Audio OK

    7) Preset change OK

    8) Inspector OK

    9) Re-loading project NOT OK - all settings will restore correctly but the preset name is gone






  • Mach Five 2.02 Motu
    Win 7 64 (32 vst)
    Failed on Scan (VST 5.1 version)  C++ runtime error R6016 'not enough space for thread data' continually looped
    Need to delete the both client and host processes

    On the surface this looks like a 64bit into 32 bit error, so I'll check and reinstall M5 to make sure I got the 32 bit version installed
  • GURU / FXpansion (Freebie included with Computer Music Mag)
    Win7 64 (32 bit plug)
    Scan OK
    Instant OK
    Audio OK
    Preset Change OK
    Inspector OK
    Reloading Project - does not retain settings and reverts to default
  • 1) Bitcrusher - CMT (free distortion/downsamlping effect)
    2) Full Version 1.01
    3) Windows 7 64-bit
    4) VST scan - OK
    5) Instantiating - OK
    6) Audio - OK
    7) Presets - OK (no presets to begin with)
    8) Inspector - OK
    9) Re-loading project - OK

  • Thank you guys!
  • Issue:

    1: Native Instruments - Maschine
    2: V 1.7.2
    3: Windows 7 64 bit
    4: VST Scan - OK
    5: Instantiating - OK
    6: Audio - OK
    7: Presets - OK
    8: Inspector - OK
    9: Reloading Project - Reverts to default
  • 1) Modartt - Pianoteq

    2) Full version 2.2.0

    3) Windows 7 32-bits

    4) VST scan OK.

    5) Instantiating OK

    6) Audio OK

    7) Preset change OK

    8) Inspector : Nothing appear

    9) Re-loading project OK

    ----------------------------------------------------------
    ----------------------------------------------------------
    1) Spectrasonic - Stylus RMX

    2) Full Version 1.9.6.e

    3) Windows 7 32-bits

    4) VST scan OK.

    5) Instantiating OK

    6) Audio OK

    7) Preset change OK

    8) Inspector OK

    9) Re-loading project OK








  • 1) Zebra 2 - uHe


    2) Registered version 2.5.2


    3) Mac OS X 10.7.4


    4) VST scan OK.


    5) Instantiating OK


    6) Audio OK


    7) Preset change OK


    8) Inspector OK


    9) Re-loading project OK




    1) Zebralette - uHe


    2) Registered version 2.5.2


    3) Mac OS X 10.7.4


    4) VST scan OK.


    5) Instantiating OK


    6) Audio OK


    7) Preset change OK


    8) Inspector OK


    9) Re-loading project OK



    1) Zebrify - uHe


    2) Registered version 2.5.2


    3) Mac OS X 10.7.4


    4) VST scan OK.


    5) Instantiating OK


    6) Audio OK


    7) Preset change OK


    8) Inspector OK


    9) Re-loading project OK




    1) ZRev - uHe


    2) Registered version 2.5.2


    3) Mac OS X 10.7.4


    4) VST scan OK.


    5) Instantiating OK


    6) Audio OK


    7) Preset change N/A


    8) Inspector OK


    9) Re-loading project OK




    1) Runciter - uHe


    2) Registered version 1


    3) Mac OS X 10.7.4


    4) VST scan OK.


    5) Instantiating OK


    6) Audio OK


    7) Preset change OK


    8) Inspector OK


    9) Re-loading project OK




    1) Uhbik-A - uHe


    2) Registered version 1.2


    3) Mac OS X 10.7.4


    4) VST scan OK.


    5) Instantiating OK


    6) Audio OK


    7) Preset change OK


    8) Inspector OK


    9) Re-loading project OK




    1) Uhbik-D - uHe


    2) Registered version 1.2


    3) Mac OS X 10.7.4


    4) VST scan OK.


    5) Instantiating OK


    6) Audio OK


    7) Preset change OK


    8) Inspector OK


    9) Re-loading project OK




    1) Uhbik-F - uHe


    2) Registered version 1.2


    3) Mac OS X 10.7.4


    4) VST scan OK.


    5) Instantiating OK


    6) Audio OK


    7) Preset change OK


    8) Inspector OK


    9) Re-loading project OK




    1) Uhbik-G - uHe


    2) Registered version 1.2


    3) Mac OS X 10.7.4


    4) VST scan OK.


    5) Instantiating OK


    6) Audio OK


    7) Preset change OK


    8) Inspector OK


    9) Re-loading project OK




    1) Uhbik-P - uHe


    2) Registered version 1.2


    3) Mac OS X 10.7.4


    4) VST scan OK.


    5) Instantiating OK


    6) Audio OK


    7) Preset change OK


    8) Inspector OK


    9) Re-loading project OK




    1) Uhbik-S - uHe


    2) Registered version 1.2


    3) Mac OS X 10.7.4


    4) VST scan OK.


    5) Instantiating OK


    6) Audio OK


    7) Preset change OK


    8) Inspector OK


    9) Re-loading project OK




    1) Uhbik-T - uHe


    2) Registered version 1.2


    3) Mac OS X 10.7.4


    4) VST scan OK.


    5) Instantiating OK


    6) Audio OK


    7) Preset change OK


    8) Inspector OK


    9) Re-loading project OK




    1) Fabfilter Volcano 2 - fabfilter


    2) Registered version 2.1.4


    3) Mac OS X 10.7.4


    4) VST scan OK.


    5) Instantiating OK


    6) Audio OK


    7) Preset change OK


    8) Inspector OK


    9) Re-loading project - Same lost preset name issue Whetstone sees for Windows



    1) Fabfilter Saturn - fabfilter


    2) Registered version 1.0.1


    3) Mac OS X 10.7.4


    4) VST scan OK.


    5) Instantiating OK


    6) Audio OK


    7) Preset change OK


    8) Inspector OK


    9) Re-loading project - Same lost preset name issue Whetstone sees for Windows

  • Good:

    1) Tyrell N6  - u-he / Amazona.de

    2) v2

    3) Windows 7 32-bit

    4) VST scan OK.

    5) Instantiating OK

    6) Audio OK

    7) Preset change OK

    8) Inspector OK

    9) Re-loading project OK



    1) Piano One - Sound Magic

    2) 1.3

    3) Windows 7 32-bit

    4) VST scan OK.

    5) Instantiating OK

    6) Audio OK

    7) Preset change OK

    8) Inspector OK

    9) Re-loading project OK


  • 1) kHs ONE - kiloHearts

    2) 1.013

    3) Windows 7 64-bit

    4-9) OK

    Slight note: Parameter names are cut of pretty short in the inspector, so it's hard to find the proper parameter since they have common prefixes that don't fit (FILTER, SHAPER, etc).
  • Hi guys, AudioGaming here !
    We will probably send our babys to you so you'll be able to test them, but before that here are some preliminary results of our own :

    1) AudioRain - AudioGaming

    2) Full version - 1.0.4906

    3) Windows 7 64b

    4) VST scan OK.

    5) Instantiating OK

    6) Audio OK

    7) Preset change OK

    8) Inspector OK

    9) Re-loading project OK

    --------

    1) AudioRain - AudioGaming



    2) Full version - 1.0.4906



    3) Windows 7 64b



    4) VST scan OK.



    5) Instantiating OK



    6) Audio stuttering: the audio buffer size has to be pretty large (>= 2048 samples) to get a clean audio output



    7) Preset change OK



    8) Inspector OK


    9) Re-loading project OK
  • Jamstix 3,   from   Rayzoon Technologies LLC 

    Full version   Vers 3.3.1  Beta 2

    Win 7 32 bit

    VST scan OK.

    Instantiating OK

    Audio OK

    Sub-plugin AudioM8 2/2 for sidechaining to another audio track does can`t be
    inserted

  • 1)Synth1 by Ichiro Toda 

    2)r 1.12 - Freeware

    3)Windows Xp/7 Ent

    4)VST Scan: OK

    5)Instance: OK

    6)VSTi

    7)Changing preset/parameters: OK

    8)Inspector: OK

    9)Loading preset/parameters: !KO! (works only if i write settings on the midi track)

  • 1.  Amplitube 3 CS - IK Multimedia

    2.  v3

    3.  MacOSX 10.8

    4.  VST Scan OK

    5. Instantiating OK

    6.  Audio OK

    7.  Preset change OK

    8.  Inspector OK

    9.  Re-loading project OK


    1.  EZDrummer

    2.  v 1.3.1

    3.  MacOSX 10.8

    4.  VST Scan OK

    5. Instantiating OK

    6.  Audio OK

    7.  Preset change OK

    8.  Inspector OK

    9.  Re-loading project OK

  • 1) MASCHINE by Native Instruments

    2) Full version - 1.8.2 R247

    3) Mac OS X 10.8.4

    4) VST scan OK.

    5) Instantiating FAIL

    6) Audio FAIL

    7) Preset change OK

    8) Inspector OK

    9) Re-loading project OK

    Maschine will sometimes lock up Ohmstudio when instantiating the plugin.  When it does instantiate, loading a new kit while the project is playing will cause Ohmstudio to lock up.  If you Force Quit Ohmstudio while it is locked up, the Maschine interface will be left on screen on top of all other windows and will not disappear unless the computer is restarted.  This is a horrible way to handle this type of situations.
  • mrforged said:

    Maschine will sometimes lock up Ohmstudio when instantiating the plugin.  When it does instantiate, loading a new kit while the project is playing will cause Ohmstudio to lock up.  If you Force Quit Ohmstudio while it is locked up, the Maschine interface will be left on screen on top of all other windows and will not disappear unless the computer is restarted.  This is a horrible way to handle this type of situations.



    Hi.

    In order to force quit Ohm Studio, you have to launch a utility program called "Activity Monitor" and kill 2 different processes (see picture below) because Maschine as well as other VSTs run in a separate process.

    This a "less horrible" way to deal with that type of situation where you had to restart your computer.

    Thanks

    image
  • Of course, thank you very much for that.

    Would it be possible for you to incorporate some code to deal with plugins that are not responding so that I don't have to use the Activity Monitor at all? That would be super! 

  • mrforged said:

    Of course, thank you very much for that.


    Would it be possible for you to incorporate some code to deal with plugins that are not responding so that I don't have to use the Activity Monitor at all? That would be super! 



    Yes, that's something we definitely want to do!
    However that's technically difficult to achieve so I cannot say when exactly.

  • Could this list be transferred to a single file  (sorted by plugin name alpha)  which is linked -  and can be updated accordingly ?   Would make it way easier to see if a plug in has been tested for this list to be updated
  • 1) TX16Wx - Cwitec Music Software

    2) Free version 2.3.0c

    3) WinXP sp3

    4) VST scan OK.

    5) Instantiating OK, does not update screen until I move it around

    6) Audio OK

    7) Preset change OK

    8) Inspector parameters not named, changing them does not seem to do anything, altough the plugin interface is on
    several pages, so I'm not sure

    9) Re-loading project: Does not remember preset, I need to re-load the preset with sounds again manually.

    Also, there is a screen update problem where the screen does not update unless I move the window around. I have 1024x768 px resloution on my X60s Lenovo laptop. The plugin also seems to cause crashes sometimes. On my 1600x1200 px desktop with WinXP the screen updates correctly.
  • Hi Taika-kim.

    Thank you for your reporting. About remembering presets, I think you should read this article: https://www.ohmstudio.com/doc/glossary/synchronization
    For some collaborative reasons, some plugins need to be "saved" manually. I think your issue comes from this. 

    Please let me know. 
  • Actually a small correction, on the bigger monitor I was using the same laptop, so it's definitely a screen size issue. I will try what you suggested now.

    Oh ans besides: all Togu Audioline TAL plugins (the free versions) seem to work 100%
  • Yes, using the manual sync the presets are correctly recalled upon project load.