Audio output very crackly

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Audio output very crackly
  • When I bounce to my project page, audio sounds like this:
    http://www.ohmstudio.com/session/4565/blue-september-version-2

    When I push "Play" and just listen, however, the audio is very disrupted.  I'm using the same ASIO driver I use in Reaper and MULAB.  I started with the same buffer size (128) then larger (256 - which the following example uses) and larger still.  Even the largest offered did not help - causing further distortion.
    http://www.drealm.info/OhmStudio/BlueSeptemberv2AsHeard.flac

    Also, playback cut off part-way through (nearly at the end), kicking me out of the project.
  • Weird... OK, there's something very strange going on.  Playing that "AsHeard" capture sounds perfect...  I'll have to try physical audio capture somehow (that was virtual).  It's obviously "going wrong" further down the signal chain than I thought.

    Just to explain further... or hopefully explain... it may confuse...

    Set up 1 - normal:
    Ohm Studio -> ASIO -> Echo Audio AudioFire4
    Experience:
    Bounce / mix down etc, are flawless; "live" play back is flawed in various ways for sequenced parts (audio playback is fine).  Flaws include crackles, distortions audio engine slow downs (i.e. pitch lowers and play back slows).

    Set up 2 - attempted audio capture:
    Ohm Studio -> ASIO -> JackRouter -> JACK -> JackRouter -> ASIO -> MULAB -> ASIO -> JackRouter -> JACK -> PortAudio -> ASIO -> Echo Audio AudioFire4
    Experience:
    Bounce / mix down etc, are flawless; "live" play back is flawed in
    various ways for sequenced parts (audio playback is fine).  Flaws
    include crackles, distortions audio engine slow downs (i.e. pitch lowers
    and play back slows).  However, capturing the "live" play back in MULAB gives flawless audio.

    Conclusion:
    The sequencer is interfering with the audio signal chain but the signal chain is remaining synchronised - hence MULAB actually captures flawless audio, despite it sounding broken up.
  • For any reason, the audio engine has not enough horsepower to generate the audio signal "in time" (remember, it only uses one thread currently). The soundcard driver regularly requests sound buffers. They have to be delivered by the application within the given time otherwise blank buffers are substituted and the sound drops or clicks. The substitution is ultimately done by the driver. Here, Ohm Studio is too slow to respect the time constraint, so in the end, you hear clicks, whatever you inserted between Ohm Studio and the driver. But it’s normal that your MULAB capture plays fine, because it gets all the buffers and only the buffers Ohm Studio generates, and Ohm Studio generates them continuously, disregarding whether it is late or not. It would be different if Ohm Studio tried to keep synchronized with an external clock, because it would have to skip buffers to catch up.

    We are trying to improve the resource use and to take advantage of all the cores for the audio processing, but anyway it’s weird you get kicked out of the session just because of a CPU overload. We’re going to investigate this issue.

    — Laurent
  • Hi PLJ....and guys....
    Ive been having same problem also lately...so I went into the preferences and set the buffers up to 1028 instead of 512..(but it didn't seem to help) .....when I use the scroll bar under the main section, like to move it back and forth to find a particular spot.. it really cracks....thought that was weird...and it has a couple of times sent me out to 'restart the audio engine'....
    just thought Id drop this line to let you know, even though you guys seem to have a rope on it...
    thanks
    harry2611
  • Hi Harry, thank you for reporting.

    Just so you know, that's exactly what the developpers have been working on lately.

    Even though the results are not satisfactory (that's why we haven't released beta#19 yet), we're making progress.

  • Unfortunately, the symptoms are still present in "Drums for you" with Beta #19 :(.
  • Hello Peter,

    Regarding performances, beta #19 is mostly the same as beta #18.
    The developpers are still working on it and although some progress has already been made, it has not been included in the latest version.
  • hi there!

    i´m having similar issues with the current beta version. my setup is a macbook core2duo with 2.4 GHz, 2 GB ram and a focusrite saffire. though not the freshest machine, this setup works fine with small projects in logic and also in energyxt.

    I cloned the project "How Wonderful(CurlyWurlyMix). Although there are only 14 audio tracks, playing back crackle free works only at 256 samples buffer or higher. with 128 samples it immediately starts to crackle. given that no instruments and fx are used, i find the cpu consumption very high.

    the activity monitor reports following figures:

    Ohmstudio OhmstudioGuest

    128 samples  65% 70%
    256 samples  60% 45%
    512 samples  70% 30%

    the figure for ohmstudio shows many spikes whereas the figures for omstudioguest are relatively steady.

    kind regards

    abi
  • ok after a restart the figures changed again considerably. with the same project (14 audio tracks) the activity monitor now reports 25% percent for ohmstudio and 40% for ohmstudioguest at 256 samples and no crackles. i´ll try no a project with some synths and fx.
  • Hi abi77

    Thank you for your feedback.

    Our developpers have some ideas on how to reduce CPU load a little with the OhmStudioGuest process (which is the audio engine) but it would require some big changes and will not happen anytime soon. Our test showed that the Ohm Studio performs (more or less) as well as other popular VST hosts program (altough it's not easy to compare performances "scientifically").

    The OhmStudio process does take a lot of CPU sometimes but it highly depends on what you're doing. For exemple when you load a project, there can can be a lot of CPU heavy tasks going on. However, one thing you can do is limit the refresh rate of the GUI in the preferences panel (there's an option called GPU consumption).

    As for the crackles, there are 2 possible known causes:
    - the first one is explained here
    - the 2nd one is the hard disk "overload" issue. It happens when you load a project with a lot of audio patterns for the first time because the ohm studio downloads and uncompress them all.

    I personally work with 512 buffer size and 44100 sample rate on a 2ghz Intel Core 2 duo and my laptop's built in sound card.

    Thanks
  • ok thanks for the answer. i´ll just stick to 512 buffer size for the moment, although it feels a little "loose" while playing mdi stuff. guess this is the price to be paid for the benefit of online collaboration. nevertheless, i´m quite excited by this host and will try to support the development of it.

    kind regards

    abi
  • Hi Abi.

    Thank you for your support.

    You can for exemple use a 256 buffer size when needed and switch to a bigger buffer size only when you have to.
    I change the buffer size only when necessary, even when I'm working on another DAW.
    It doesn't resolve the problem but it's a way to get around it sometimes :)

    Also don't forget that you can temporarily "freeze" a Rack to save CPU.

  • MME is also pretty useless for audio. ASIO from M-Audio works fine, ASIO 4 all works OK. And that is with a weak track load.
  • If you are working with limited bandwidth (DSL) you need to bump the buffer up to 1024 or 2048 on an older computer (like at work when you should be working instead of playing with Ohm Studio). At those buffer settings you're limited to data entry or clip insert MIDI, but it is still functional under marginal operating conditions.